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Introduction 

Navigating QuickLoad Central 
The File Stores tab allows you to add or remove the saved locations where STDF files are stored. You 

can also select to show files from only one file store, or from all file stores. 

From the Filter tab, you can apply filter criteria to narrow the list of files and lots shown on the 

Dashboard. 



The Analytics Dashboard tab, or Dashboard, includes the majority of the available options for 

working with STDF data. 

On the Logs tab, log messages are shown for all operations, including many changes to configuration 

settings. To clear the log, right-click and choose Clear Log. 

Viewing QuickLoad-Central Information 
From the File Stores tab, the Filter tab, or the Dashboard, you can click About QuickLoad-Central in 

the bottom right corner to open the About window. This window shows the software version, your 

license number, and information about the components of QuickLoad-Central. You can also register 

a new software license from this window. 

Registering a License 
1. From the About QuickLoad-Central window, click Register New License. 

2. In the Input dialog box, type or paste your license number. 

3. Click OK. Your new license is registered.  

Managing File Stores 
File Stores are the folders where QuickLoad-Central looks for STDFs (including gzipped ones) to 

preprocess and show on the Analysis Dashboard.  This is not applicable to QuickEdit.  Subfolders of 

File Stores will also be searched. 

Adding File Stores 
1. Launch QuickLoad-Central. The Getting Started dialog box opens. 

2. Click OK. The Choose a folder window opens. 

a. From the File Stores tab, you can also click Add or right-click and select Add File 

Store.  

3. Browse to a location where STDF files are stored. 

4. Click Open. The file store is added to the Dashboard. 

Removing File Stores 
1. From the File Stores tab, click the file store you want to remove. 

2. Click Remove. The file store is removed from the Dashboard. 

a. You can also right-click the file store and select Remove File Store. 

Managing the File List 

Filtering by File Store 
To show files from only one file store: 

1. From the File Stores tab, right-click a file store and select Show Only Files from This File 

Store. 

2. Files from the selected file store are shown on the Dashboard. 

To show files from all file stores: 



1. From the File Stores tab, right-click and select Show Files from All File Stores. 

2. Files from all file stores are shown on the Dashboard.  

Filtering the File List 
To apply filter criteria: 

1. Click the Filter tab. 

2. Enter filter criteria in one or more fields. Fields may be left blank. 

Note: Filters will add a wildcard before and after the search strings you enter.  Text filters are case-

insensitive.  For example, abc in the Lotid filter will match a file with lotid ABC (or ABCD because of 

the automatic wildcard). 

3. Click Apply Filter or press Enter. A filtered list of files is shown on the Dashboard. 

To remove filter criteria: 

1. Click the Filter tab. 

2. Click Clear Filter. The filter fields are cleared and all files are shown on the Dashboard. 

a. From the Dashboard, you can also right-click and select Remove Current Filter. 

Selecting Files 
To select a file from the Dashboard, select the check box for the file. You can also right-click and 

choose Select All Files or Unselect All Files. 

Using the File List Management Menu 
From the Analysis Dashboard, you can right-click to access the File List Management menu. This 

menu includes the following options. 

Option Description 

Reprocess Selected Files Reprocesses the selected files based on the current configuration 
settings 

Forget Selected Files Removes the selected files from the file list 

Add Comments to 
Selected Files 

Opens a dialog box for each selected file; enter a file description 

 

Editing Lot Attributes 
1. From the Dashboard, select the check box for each file you want to edit lot attributes for. 

a. If you select multiple files, the lot attribute values you enter will be applied to all of 

the selected files. 

2. Right-click and choose Edit Lot Attributes. 

3. From the Edit Lot Attributes dialog box, enter values for the following fields as needed: 

a. Lot ID 

b. Sublot ID 

c. Testcode 

d. Wafer ID 

e. User Text 



f. Flow ID 

g. Proc ID 

h. Mode Code 

i. Retest Code 

j. Temperature 

4. Optionally, select the Insert WRR If Missing check box to insert a Wafer Results Record in 

any selected file that is missing one.   

5. Click OK. 

Merging Files 
1. From the Dashboard, select the check box for a file. 

2. Right-click and choose QuickEdit Selected Files. 

3. From the QuickEdit window, click File and choose Merge STDF. 

4. From the Open STDF File dialog, browse to the file you want to merge and click Open. The 

selected file is merged with the file that was already open. Some header information of the 

selected file may be discarded when the files are merged.  

5. Click the save icon to save the merged file. 

Merging normally merges the current file and the new selected files into the equivalent of one file.  

However, if the “Merge Wafers When Merging Files” option (under Options->File Loading) is 

checked.  Each wafer will be merged separately.  For example, if you loaded a file from wafer 1 and 

merge in 1 file from wafer 1 and 2 files from wafer 2, the resulting data in memory will have one set 

of records for wafer 1 and one set for wafer 2. 

Data Views 
These views are available as tabs in QuickEdit, and can be opened from the View menu.  They are 

also available as output formats in QuickLoad-Central under “Send Data to Excel”, “Send Data to 

JMP” and “Manage Auto-generation of Extracts”.  There are two types of data views 

• Views based on STDF record types.  These views show all instances of a given STDF record 

type (for example the Master Information Record or Parametric Test Results record) in the 

loaded files and are editable. 

• Reports derived from the data in the loaded STDFs 

Table Description 

All Records All STDF records in the loaded file.  Useful for editing specific 
records 

Bin % Pareto Shows all bins and the % for each. Soft/hard and separated by lot 
and wafer are controlled by File Summary configuration options 

Bin Count Pareto Same as Bin % Pareto except with counts instead of % 

File Summary Multi-table report. Shows basic info about first file (lot, program, 
etc), part counts, bin counts, test fail counts.  Has many 
configuration options such as breaking data down by lot and wafer 
and whether to show site-specific counts 

Lot Tree Hierarchical view of files, lots, tests, parts 



Lot Yield For each lot shows the number of units tested and failed 

Multiple Results by Test Shows one row per test, one column per unit.  For MPR (multiple 
results per test) tests shows one row per pin per test, which is how 
it is different from Results by Test 

Parametric Results Important view with one row per unit, one column per test, plus 
lots of descriptive columns.  Has many filter options. 

Part Summary Has one row per unit, with columns with information about the 
unit.  Similar to Parametric Results but with only the columns 
describing the unit. 

Part Test Rows Has one row for each test for each part.  This table can get quite 
large, so it is best to use it with small files. 

Record Type Counts Shows the total number of records for each STDF record type in the 
loaded files 

Results by Test Important view with one row per unit, one column per test.  Has 
many filter options. 

Stacked Bin Map Shows the number of occurrences at each x,y location of each bin.  
Normally used when loading multiple wafers together.  Soft vs hard 
bin is controlled by Wafer Bin Map use hard bin option. 

Statistics Shows common statistics for each test (median, yield, mean, cpk, 
etc.) 

Test Conditions Will show identified test conditions if one of the test condition DTR 
options is selected and followed in the loaded files. 

Test Descriptions Shows key information about each test (limits, test order, etc.) 
Limits can be edited here. 

Test Fail % Shows number of tested, failed, yield % for each lot or wafer for 
each test 

Validation Errors Identifies problems and spec violations in the loaded STDFs 

Wafer Bin Changes For wafer data with multiple files loaded, shows x/y locations with 
bin changes between files 

Wafer Bin Map CSV Tabular wafer map 

Wafer Bin Table One row per x/y location, shows bin value for each file loaded that 
has wafer data 

 

 

Changing Configuration Settings 
From the Dashboard, right-click and select Configuration, then select the check box for a 

configuration option to enable it. To disable a configuration option, clear the check box for the 

option. 

If you open a file in QuickEdit and change configuration settings from the Options menu, they will 

automatically be updated in the Configuration menu of the Dashboard. Likewise, any settings you 

change from the Dashboard are also updated in QuickEdit. 

The Configuration menu includes global settings, PAT Limits, Sanity Limits, and the following 

submenus: 

• Charts 



• File Loading 

• File Saving 

• File Summary 

• Parametric Results 

• Tests 

• Wafer Bin Map 

Global settings, PAT Limits, and the options for each submenu are described in separate sections. 

Global Settings 
Option Description 

Convert File Store CSV and WAT to 
STDF 

QLC will attempt to convert files with CSV or WAT suffixes 
to STDF if they are found in one of the File Stores.  
Conversion will only work if the CSV is similar to the 
format used by QLC/QE Parametric Results or if the WAT 
file uses the TSMC WAT file format. 

Extra Logging Of Report Generation Will include extra logging of automatically generated 
reports. 

Include Out of Sequence Test Results Causes QE & QLC to include test results in association 
with the next part if they are not properly logged 
between the PIR and PRR.  This problem does not occur 
often. 

Pregenerate File Statistics Automatically generates file statistics in the background 
when you open QuickLoad-Central. 

Read Test Conditions from DTR with 
COND:name=value,[name=value]… 

Reads test conditions from the Datalog Text Record (DTR) 
if the DTR record starts with “COND:” and then defines 
the condition as key value pairs separated by commas, for 
example “COND:temp=25,voltage=7”.  Each test condition 
for a part will have its own row in the “Parametric 
Results” table. 

Read Test Conditions from DTR with 
Custom Key Name 

Reads test conditions from the Datalog Text Record 
where the record text is keyname=value and the keyname 
is defined using the “Customize Test Condition Key” 
option on the Options menu.  For example, if the custom 
key name is “INC” the DTR text entry could be “INC=25”.  
Test conditions will be shown in “Parametric Results” as 
described above. 

Read Wafer Info From DTR QLC & QE will attempt to read the wafer id from DTR 
(datalog text) records if the DTR follow certain standard 
formats.  Usually this is used for final test data where the 
wafer information is stored on each part. 

Remove Deleted Files From 
Dashboard 

If files are deleted from the file store their information 
will be removed from the database and dashboard. 

Save All Data in DB (Postgres Only) If you are using a Postgres db to store the data instead of 
the default sqlite, additional information will be cached 
about files. 

Use File-based Dashboard See Use File-based Dashboard Options 

Use UTC Instead of Local Time Uses Coordinated Universal Time (UTC) instead of local 
time for various date fields 



Set Storage Location for Database By default, QuickEdit and QuickLoad-Central both use a 
sqlite database.  This is included with the installation.  If 
you want to use sqlite but with a file stored in a non-
default location, choose the “Set Storage Location for 
Sqlite Database File” sub-option and choose the directory 
where the file will be stored.   
If you want the same database to be used by several 
users, especially for QuickLoad-Central, sqlite may not 
work well because only one user can open the file at a 
time.  In this case, QuickLoad-Central will also work with a 
Postgresql database. Instructions for downloading  and 
setting up Postgresql are outside the scope of this 
manual, but you can configure QuickLoad-Central to use a 
new or existing Postgresql database. Choose the sub-
option for “Set Postgresql DB Location” and enter the 
requested configuration information.  For best results, 
restart QuickLoad-Central after setting this option.  Once 
this is done, QuickLoad-Central should then work 
smoothly with multiple users. 

 

Use File-based Dashboard Options 
The Dashboard shows different columns when Use File-based Dashboard is selected or cleared. 

Columns in italics are shown with either Use File-based Dashboard selection, although the columns 

may change position.  

Selected 

Lotid Sublotid Start Time File Name Part Type 

Program Program Rev Parts Good Parts Tests 

Yield Avg Test Time File_Size Testcode Tester 

 

Cleared 

Part Type Program Program Rev Lotid Sublotid/Waferid 

Test Code & 

Temperature 

Test Step (retest 

step) 

Tester & 

Operator 

Handler/Probe 

Card 

Start & Finish 
Time 

Parts Good Parts Yield Top Fail Tests Avg Test Time 

 

Configuring PAT Limit and Sanity Limit Preferences 
1. Right-click and select Configuration, then click PAT Limits Configuration. The Define PAT 

Limit Preferences dialog opens.  Click Sanity (Outler) Limits Configuration for an equivalent 

dialog that controls sanity limits that are optionally used to remove outliers from charts. 

2. Click the list and choose one of the following options for the center point and standard 

deviation version: 

a. Center:Mean and Sigma:Standard Deviation 



b. Center:Median and Robust Sigma:IQR/1.349 

3. Enter a number in the Sigma Count field, or click the up and down arrows to change the 

number. 

4. Click OK. 

Chart Options 
Option Description 

Assuming Missing Retest Point 
Matches Original in Kappa 

For Kappa Correlations between probe and reprobe, if an X/Y 
location lacks a value in the reprobe file, assume it has the same 
bin as in the original file 

Default Zoom to Limits Zoom charts to limits rather than data 

Generate Separate Pareto Per 
File 

Shows a separate pareto chart for each selected file 

Include Bin Name in 
Description 

Adds the bin name to the bin number in charts 

Include Goal Cpk in Test Stats 
Table When Set 

Include the goal Cpk with test statistics 

Include Others Category in 
Paretos 

Combine all residual bins or tests into an Others group and 
include that in the pareto 

Maximize Plot Window Size Opens charts in maximized windows 

One Point Per File on Yield 
Trend 

Show one point per file rather than one point per lot on Yield 
Trend chart 

Show Count on Pareto Show the numeric value of each bar on pareto charts 

Show One Plot Per Page Shows one plot per page when saving charts to PDF 
Show Pct on Pareto Show the pct of total of each bar on pareto charts 

Use Partid as X Value On Trend 
Charts 

Use the partid as the x value, rather than using the index in the 
dataset. 

Use Small Point Size in Charts Shows smaller sized data points in charts  

 

File Loading Options 

Option Description 

Always Recreate STDF 
Summary Records 

When selected, STDF summary records are automatically 
recreated. 

Merge Simultaneously Open 
Files 

When selected, if you open an additional file, it will be merged 
with the first file you opened. Some header information will be 
discarded from the second file. 

Merge Wafers When Merging 
Files 

Merges files for each wafer separately if multiple wafers are 
present in a merge.  They will all be on one view, but they will 
be combined separately under each wafer id, each having its 
own set of summary records, unique x/y values, etc. 

 

File Saving Options 
Option Description 

Save All Test Info in Every 
Record 

When selected, all test information is saved in every record, 
even if some of the test information is identical for all records. 

 



File Summary Options 
Option Description 

Include Hard Bins in Summary Show counts and description for each hard bin 

Include Head in Site 
Description 

Most files only rely on test site and not test head, but 

technically STDFS rely on both, and both are shown with this 

option 

Include Only Last Result for 
Each Test for Each Part 

If a test is performed multiple times for a part, only the last one 

will be included in test summary statistics 

Include Lots Make a separate column for each lot in the File Summary table 

showing number of units tested and failed 

Include Site Results Shows separate soft bin counts and percentages for each site 
Include Soft Bins in Summary Show counts and description for each soft bin 

Include Sublots Make a separate column for each wafer in the File Summary 
table showing number of units tested and failed 

Separate Lots by Test Stage Show separate counts for each test stage for each lotid.  

Show Empty Bins Shows the bin records for empty bins 

Use Current Limits When 
Recreating Summaries 

Recreates summaries using the current edited limits, not the 
original limits in the file 

 

 

Parametric Results Options 
Option Description 
Describe Pin With Channel 
Name 

Uses the channel name for the pin when building test names for 
tests derived from MPR records, that is tests that reported one 
result for pin. 

Describe Pin With Logical 
Name 

Uses the logical name for the pin in names for tests derived 
from MPR records.  

Describe Pin With Physical 
Name 

Uses the physical name for the pin in names for tests derived 
from MPR records. 

Display Scaled Test Results When selected, the scale listed for the test in the file will be 
used in displayed results.  For example, if the unit for a test is V 
and the scale is 3, results or limits will be displayed as mV.  If the 
scale is –3, they will be displayed as kV. 

Display Scaled Test Results 
Using Format String 

Formats results using a format string provided in the file, after 
scaling the result as described above.  This defines the number 
of digits shown before and after the decimal point. 

Display Unscaled Test Results 
Using Format String 

Formats results using a format string provided in the file.  This 
defines the number of digits shown before and after the 
decimal point. 

Ignore Test Plan Delimiter Some testers record a fake part called “Test Plan Delimiter”, 

possibly with test config info.  Omit this part from part lists and 

summaries. 

Show Cycle Count for FTR For functional test results show the cycle count field as the 
result for the test 



Show Limits as First Rows Shows rows for low and high limits and units at the top of the 
Parametric Results view.  This is especially useful when 
exporting data to CSV or Excel. 

Show Non-Test Rows First in 

Results By Test 

In the Results By Test view show first the rows that do not show 
test results. 

Show Only First Failed Test In the list of failed tests for each part show only the test that 
failed first, according to results order in the file. 

Show PF Per Test Shows a Pass/Fail result for each test for a part. 

Sort Tests By Test Order Shows tests in the order they first occurred in file, rather than 
alphabetically 

Use Part Sequence Instead of 

Partid 

Some test platforms do not provide a valid partid.  This option 
says to use the sequence (ie 1 for the first part, 2 for the second, 
etc.) as the partid 

 

Parts Options 
Option Description 

Create Missing PRR If the file contains PIR without a missing PRR, create them.  This 
usually happens in a file that ended unexpectedly. 

Force Superseding of Duplicate 
Partids 

For repeated partids only the latest value is shown and included 
in counts. 

Force Superseding of Duplicate 
X/Y Parts   

Data may contain duplicate X/Y combinations, often the result 
of retesting the same part. When this option is selected, the 
latest duplicate X/Y parts are shown by default in views such as 
Parametric Results. When it is cleared, all duplicate X/Y parts 
are shown. 

Include Original Results of 
Retested Parts in Counts 

When selected, counts on File Summary and Statistics analysis 
will include all results for retested parts. When cleared, counts 
only include the latest results for retested parts. 

Use QRTAG GDR Entries as 

Partid 

If the file had Generic Data Records matching certain 
conventions, they will be treated as a serial number stored on 
the part and used as the Partid. 

 

 

Tests Options 

Option Description 

Allow Multiple Tests Per Name Allows tests to be created that share a name but have different 
number 

Allow Multiple Tests Per 
Number 

Allows tests to be created that share a number but have 
different names 

Allow Multiple Tests Per 
Number But Share Limits 

Identifies tests by the combination of number and name, but 
tests share limits 

Allow Variable Limits Allows the limits for a test to change during testing 

Include Test Name in Displayed 
Test Name 

Includes test name in test-based column headers 

Include Test Number in 
Displayed Test Name 

Includes test number in test-based column headers 



Include Units in Displayed Test 
Name 

Includes test unit of measure in test-based column headers  

Make Separate Test Per MPR 
PIN 

For Multiple Parametric Results tests, creates a separate test in 
views such as Parametric Results for each pin used for test 

Merge Programs When 
Loading Multiple Files 

When multiple files are being loaded, merge programs so that 
equivalent tests are combined. 

Store Part Test Time as Test Treat the test time of each part as a test to support visualization 

of test time. 

Trunc Test Names At First 
Space 

Truncates test names at the first space in the name.  This may 
affect uniqueness. 

 

Wafer Bin Map Options 
When all Wafer Bin Map options are cleared, only soft bin numbers are shown in the chart. The 

options allow you to include the bin count and bin name, or use hard bin data instead of soft bin 

data.  Additional wafer map options such as rotation are available using the “Wafer Map, Custom 

Stacked or Bin” chart. 

Option Description 

Include Bin Count in Wafer 
Map 

Shows the bin count in parentheses in the wafer map 

Include Bin Name in 
Description 

Shows the bin number and name in the wafer map 

Include Bin Percent on Wafer 
Map 

Include bin percent on wafer map legend 

Reverse X Axis of Wafer Map  

Reverse Y Axis of Wafer Map  

Show Bin Number on Wafer 
Map 

Include bin number on wafer map legend 

Show Surrounding Grid on 
Wafer Map 

Show not just the wafer, but the surrounding cells of the grid.  
This sometimes facilitates viewing edge die or non-standard 
shapes, for example from strip test. 

Show Wafer Edge on Wafer 
Map 

Draws the edge of the wafer 

Use Hard Bin in Summary and 
Wafer Map 

Shows hard bin data in the file summary and in the wafer bin 
map (also a File Summary option) 

 

  



Making Charts 
You can make charts for a single file, or for multiple files at the same time. For some chart types, a 

separate chart will open for each file; for others, the charts will show combined data for all selected 

files, grouped by file. 

1. From the Dashboard, select the check box for each file you want to make a chart for. 

2. Right-click and choose an option from the Make Charts menu. 

a. For some options, a separate chart is shown for each selected file. 

b. For other options, a combined chart is shown with data grouped by file. 

c. In QuickEdit, make charts by selecting an item on the Charts menu 

3. From any chart, you can right-click to access options to copy, save, or print the chart. You 

can also zoom in or out, select auto range, or view chart properties. Some charts have 

additional options, such as zoom to data or zoom to limits. 

4. Available Charts 

Chart Name Description 

Bin Failure Pareto Pareto of failure bins, showing bars for most frequent bins and 
cumulative curve 

Bin Pareto Like Bin Failure Pareto but includes all bins 
Box Plot Graphically depicts groups of data through their quartiles 

Combine Plot Types Includes multiple selected charts, for example statistics and histogram for 
each selected test 

Drift Analysis Trend chart with additional statistics showing additional statistics about 
differences between the parts in the 2+ groups, if all groups have same 
number of parts 

Gauge R&R Analysis of differences between groups, if all groups have same number 
of parts 

Histogram Divides results into bins of equal range and shows bar plot of number of 
parts in each bin 

Kappa Correlation Tabular analysis of bin result changes between two files 

Limit Analysis Enables what if analysis for new limit or Cpk values.  Includes all fields 
from Statistics, updating failure counts & Cp* based on new limits or goal 
Cpk.  If used in Combine Plot Types, limit lines on other plots are also 
updated for new hypothetical limits 

Normal Probability 
Plot 

Plots actual results against percentage of normal result 

Scatter Plot Plots results of one test against another with one point showing the 
results of each part for the two tests 

Stacked Bin Map For each bin (or selected bin for custom stacked map) draws one wafer 
map showing the percentage of units at each x/y location that have the 
applicable bin(s).  Primarily useful when you have loaded or selected 
multiple wafers 

Statistics Tabular showing statistics for each test (or each test for each group) such 
as low, high and total failure count and yield, quartiles, standard 
deviation, Cpl, Cpu, Cpk 

Test Bar Chart A chart showing the selected tests, with the % of units tested and failed 
for each. 

Test Fail Pareto Pareto of tests that failed the most frequently in the included data 

Trend Chart X/Y plot with parts on X axis and test result on y axis 



Wafer Bin Map Classic wafer map with one color per bin, showing bin at each location on 
wafer 

Wafer Map, Custom 
Stacked or Bin 

Generates bin or stacked wafer map with various configuration options 
such as defining bins to be stacked and rotating wafer 

Wafer Parametric 
Map 

Divides results for selected tests into ranges, assigns colors to the ranges 
and then shows the applicable color for each die location 

Yield Trend X/Y plot of yields.  X is configurable typically has one entry per lot, 
ordered by time, with yield on y scale 

For Combine Plot Types, select the check box for each type of plot you want to combine in the chart.  

For Bin Pareto, Bin Failure Pareto, Kappa Correlation, Stacked Bin Map, Stacked Pass Fail Map, Test 

Fail Pareto, Wafer Bin Map, Wafer Map Custom Stacked or Bin, Wafer Pass Fail Map, and Yield 

Trend, you do not need to enter parameters. 

For Box Plot, Drift Analysis, Gauge R&R, Histogram, Normal Probability Plot, Scatter Plot, Statistics, 

Test Bar Chart, Trend Chart, and Wafer Parametric Map, you will enter parameters to determine 

the chart display.    

Making Charts with Parameters 
1. From the Select Tests to Include dialog, highlight  each test you want to include in the chart 

by clicking with the mouse.  Hold down the control key while clicking to select multiple tests 

or hold down the shift while clicking to select a range of tests. 

2. To divide the results for each test into multiple groups, click Grouping Level 1 and select a 

column to group by (for example Lot id, Sublotid (waferid) or Test_site). 

a. Repeat this with Grouping Level 2 and Grouping Level 3, if needed. 

b. You can limit the set of values to include for any of the grouping levels being used by 

clicking “Filter Input File Values”, highlighting the values to include, and clicking OK. 

3. Enter values for Graph Label, X Axis Label, and Y Axis Label, if needed. You can also leave 

one or more of these fields blank to use the default values. 

4. Select or clear the check box for each of the following options (some options do not apply to 

all charts): 

a. Draw spec limits: shows spec limits on the chart  

b. Draw PAT limits: shows PAT limits on the chart 

i. You can define PAT limit preferences by selecting PAT Limits from the 

Configuration menu.  

c. Filter outliers with sanity limits: does not show values that occur outside of the high 

and low sanity limits 

i. Click View/Edit Sanity Limits to adjust the high and low sanity limits as 

needed. 

d. Filter Part List: opens a dialog where you can select parts to exclude  

e. Draw separate plot for each group: shows a separate plot for each group, rather 

than showing all groups on one chart  

f. Separate plot per test pin: for tests with one result per pin from MPR records, 

charts each pin separately 

g. Show one plot at a time: shows each chart separately and provides Next Chart and 

Prev Chart navigation buttons, rather than showing all charts at once 

h. Label group values: shows a label with the values for each group 



5. For Histogram, you must select one of the following options: 

a. Fast Bin Calculation: 

b. Optimal Bin Calculation:  

c. Specify Bin Count: enter a value for the bin count 

d. Specify Bin Width: enter a value for the bin width 

6. Histogram also includes the Draw Normal Curve option. Check the box for this option if you 

want to show the normal curve on the chart. 

7. Trend Chart include the Draw Groups Sequentially option. Check the box for this option to 

show groups in a sequential order. 

8. Trend Chart, Drift Analysis and Scatter Plot include several Fit Line Using Method options. 

Choose from the following options to connect points or fit a line to the data. 

a. No Line: does not show a line 

b. Connect Points: shows lines connecting points along the x-axis. 

c. Ordinary Least Squares Regression: fits line to the points using least squares 

d. Polynomial Regression: 

e. Power Regression: 

9. For Gauge R&R you must have multiple files loaded together but not merged.  Parts are 

implicitly compared and you should choose one or more other groups, for example tester 

and test site. 

10. For Drift Analysis, load two or files with data for the same partids.  Group by input file, or 

equivalent.  The analysis will draw the trend chart with additional fields characterizing the 

drift between group values at the bottom of the chart.   

11. To change the chart type to be draw, or include additional ones, click Change Chart 

Type, then check the chart types to be included. 

12. Click OK. 

Managing Auto-generation of Extracts 
From the Manage Auto-generation of Extracts menu, you can set the root location for extracts and 

select which extracts will be auto-generated when you launch QuickLoad-Central. 

Setting the Root Location for Extracts 
1. From the Dashboard, right-click and select Set Root Location for Extracts from the Manage 

Auto-generation of Extracts menu. 

2. From the dialog box, browse to the folder location where you want auto-generated extracts 

to be stored. 

3. Click Open. 

Enabling Auto-generated Extracts 
When you enable an auto-generated extract option, the extract is immediately auto-generated for 

each file and saved to the root location. Extracts are also processed for each new file you add, as 

long as the extract option is still enabled.   

1. From the Dashboard, right-click and select the check box for an option in the Manage Auto-

generation of Extracts menu. 



2. To enable another auto-generated extract option, right-click and choose to the Manage 

Auto-generation of Extracts menu. Select the check box for the auto-generated extract you 

want to enable. 

Viewing Extract and Report Files 
1. From the Dashboard, select the check box for each file you want to view extract and report 

files for. 

2. Right-click and choose Show Generated Extracts and Reports. The Extract and Report Files 

window opens, showing a list of files. 

3. Right-click a file and select Open File or Open Folder Containing File. 

Exporting Data 
You can select files and send data to Excel or JMP. You can also export data from selected files to a 

CSV file or export the current dashboard data in CSV format. 

Sending Data to Excel 
1. From the Dashboard, select the check box for each file you want to send to Excel. 

2. Right-click and choose Send Data to Excel, then choose a report option. Table… lists the 

available reports. 

3. The data is saved to a CSV file in a subfolder of your root location for extracts, and 

QuickLoad-Central attempts to open the file in Excel or whatever application is associated 

with CSV files on your system. 

Sending Data to JMP 
1. From the Dashboard, select the check box for each file you want to send to JMP. 

2. Right-click and choose Send Data to JMP, then choose a report option. Table… lists the 

available reports. 

3. The data is saved to a JSL file in a subfolder of your root location for extracts, and QuickLoad-

Central attempts to open the file in JMP. 

Exporting Data to a File 
1. From the Dashboard, right-click and select Export Data to File, then choose Parametric 

Results. 

2. From the Save window, browse to the folder location where you want to save the file. 

3. Enter a file name. 

4. Click Save.  

Exporting the Dashboard 
1. From the Dashboard, right-click and select Export Dashboard. 

2. From the Export Dashboard window, browse to the folder location where you want to save 

the current dashboard data. 

3. Edit the filename as needed and add a file extension, such as .csv or .txt. 

4. Click Save. An Export Complete message is shown. 



Editing Files 
To open files for editing from the Dashboard, select the files, right-click and choose QuickEdit 

Selected Files. 

The first time you open a file with QuickEdit, the File Summary table is shown. The Parametric 

Results,  All Results, Hardware Bin Records (HBR), and Software Bin Records (SBR) tables also open 

by default. The tables that are shown when you close a file will be shown the next time you open a 

file. 

To open additional tables, right-click and select an option from the View Report Table menu or the 

View STDF Record Type Table menu. 

To close a table, right-click it and select Close Current Table. 

When you right-click a table, you also have options to find a column; sort table rows; cut, copy, and 

paste data; and export data to a CSV file. 

From the File Summary table, you can right-click a parametric test and choose Statistics, Box Plot, 

Histogram, Normal Probability Plot, or Trend Chart to view the selected chart for the test. 

From other tables, such as Parametric Results, you can right-click a record and choose options to 

edit or delete it. The Edit option opens a dialog box containing the fields you can edit within the 

record. 

Managing Files in QuickEdit 

Opening New Files 
1. Choose Open from the File menu or the open icon from the toolbar. 

2. Browse to the file location and click Open. 

Opening Recent Files 
1. Choose Open Recent Files from the File menu or from the toolbar. 

2. Select the check box for each file you want to open and click Open Selected Files. 

Viewing and Editing STDF Files 

Sorting Data 
To sort data in most tables, click any column header. In most views you can also sort by multiple 

columns. 

1. Right-click and choose Sort Table Rows. 

2. You can click Restore Original Order to go back to the original sort order of the file, or click  

Reverse Original Order to reverse the original sort order of the file. 

3. To sort by multiple levels, choose an option from the Column For Next Sort Level list and 

click Add Sort Level. 

a. You can select the Sort Z-A check box to add Z-A sorting for the selected column. 



4. To remove one or more rows from the sorting list, select the check boxes for each one in the 

Delete column and click Delete Selected Rows. 

5. Click OK.   

Editing Data 
1. Choose a tab. 

2. Right-click in any cell and choose Edit [record type]. For example, choose Edit MIR. 

3. A window opens, showing editable fields sorted in the order they appear in the file. Edit 

values as needed and click Save. 

Adding Data 
1. Choose Create Record from the Edit menu. 
2. Choose the type of STDF record you want to create. 
3. Enter values for the new record. 
4. Click Create. 
5. Choose a location within the file for the new record. 

a. If needed, you can edit the values in a record after you create it. 

Recalculating Statistics after Editing Data 
1. From the View | Reports menu, choose Test Descriptions. 

2. To edit the test name, number, limits or unit, click the corresponding cell, edit the value, and 

then click in another cell. 

3. To remove tests, highlight all or part of the rows for the tests you want to delete. Right click 

and choose Delete Selected Tests. 

4. From the Options | File Summary menu, select Use Current Limits When Recreating 

Summaries. 

5. From the File menu, choose Recreate Summary Records. All pass/fail information for the 

test is recalculated using the new limits. 

6. From the File menu, choose Save As to save your changes into a new file. 

Saving New Files 
You can save a new file in STDF, CSV, XLSX, JSL, or HTML format. 

1. From the File menu, choose Save As. You can also click the save button on the toolbar. 

2. In the new window, enter a file name and choose the location where you want to save the 

file. 

3. Click Save. 

Filtering QuickEdit Views 
The views showing part and test raw data (Parametric Results, Results by Test, Multiple Results by 

Test) have filters available to help the user focus on the data of interest.  If a filter has been applied, 

all charts and exports will only show the current data until the filter is removed. 

1) Exclude 



a. Exclude Superseded Parts—hide parts that are known to have been retested later, 

either from matching lot + wafer + x + y or by matched lot + serial number or if the 

superseded flag is set on the STDF PRR record. 

b. Exclude all retests of parts—identified in the same ways as #1, except for the 

superseded flag. 

c. Excluded Selected Hard Bin, 

d. Exclude Selected Soft Bin , 

e. Exclude Selected Site —hide all parts with the same value for the selected filter field 

as the parts in the currently selected rows (or columns for views with the parts as 

columns such as Results by Test). 

f. Excluded Failed Parts—hide all parts with the fail flag set. 

g. Exclude Tests With Failures—hide all tests that were failed for any parts. 

h. Exclude Failed Parts and Tests—combines #6 & #7. 

i. Exclude Parts Failing Selected Tests—excludes all parts that failed any tests that are 

highlighted. 

j. Exclude Selected Parts—excludes all highlighted parts. 

k. Excluded Selected Tests—excludes all highlighted tests. 

2) Include—most of the include options are the same as the exclude options, except only the 

affected rows are shown, instead of the affected rows being hidden. 

a. Define Test Name Filter...--this allows the user to specify all or part of a test name 

and keep only the matching tests. Multiple filters can be entered, with a space, then 

the word OR, then another space between filters. 

3) Show Random Sample—a random set of parts will be retained. The user can choose to keep 

1, 10, 25, or 50% of the parts. 

4) Clear—clear all test-based filters, part-based filters or all filters. 

Retest Data in File Summaries 
1. To only show bin and test counts for the latest testing of each X/Y and partid, make sure the 

option “Include Original Results of Retested Parts in Counts” is not checked.  Otherwise all 

testing will be included. 

2. This affects all bin counts, test execution and failure counts in the File Summary view as well 

as the Statistics chart (which is actually a data table). 

Raw Data Views 
1. Whether parts that were tested again later (superseded parts) are shown in raw views such 

as Parametric Results is controlled by two settings. 

a. If the option “Force Superseding of Duplicate X/Y Parts” is checked, by default 

superseded data for a part are not shown. 

b. The Filter Data option on the right click menu of Parametric Results can control this 

several ways 

i. Exclude Superseded Parts and Include Only Latest Testing will both exclude 

rows that do not represent the latest testing of a part. 

ii. Exclude Retested Parts and Include Only First Testing will only show the first 

time a part was tested. 

iii. Clear Filters will remove these options and show all parts. 



Creating STDF from Other Formats Using QuickEdit 

Make STDF from CSV 
QuickEdit can create STDF files from CSV, but only if the CSV follows an expected structure.  The 

structure matches that created by exporting Parametric Results to CSV from QuickEdit, with a few 

additional fields available as noted below.   If you need an example file to create this format, please 

contact us. 

1. Click QuickEdit Advanced menu and choose Make STDF From CSV 

2. Choose the csv file name 

3. After the file loads choose File menu, Save As to save the new data as an STDF.  Or you can 

proceed with analysis. 

The following additional column names can be used in the CSV that are not currently in the 

Parametric Results export format: 

• start_t (file test start time) 

• finish_t (file test finish time) 

• tstr_typ (tester type) 

• cabl_id 

• card_id 

• cont_id 

• dib_id 

• extr_id 

• hand_id 

• lasr_id 

• load_id 

Tips for successful use of the CSV to STDF tool 

• Header values (ie values not specific to a part such as part id or x location or to a test result) 

are only read from the first row in the file that represents a part 

• If you export Parametric Results to csv you will see the format for including test limits and 

units in the csv.  CSV to STDF will read this same format 

• You can add additional test columns at the end of the file before loading it back into 

QuickEdit.  This is an excellent way to add calculated values to an STDF and chart them in 

QuickEdit. 

Make STDF from JSON 
QuickEdit can export JSON files that contain one entry per record in the file.  These JSON files can be 

edited and then imported into a new STDF using this option. 

Make STDF from TDTF 
This will create an STDF file based on standard interpretation of a TDTF (Tester Data Text Format) 

file. 



Make STDF from WAT 
This will create an STDF file base on standard interpretation of a WAT export from certain foundries. 

Creating from Other Formats 
The API underlying QuickEdit is designed to allow easy incorporation of other data formats, for 

example from non-STDF testers and foundry Etest files.  If you are interested in adding one of these 

contact us at sales@sprysoftware.net. 

 

This manual copyright Spry Software, Inc., 2020.  QuickEdit and QuickLoad-Central applications are 

copyright Spry Software, Inc., 2005-2020. 
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